Real Time Ascend Maling List Archive
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: (ASCEND) Cisco 804 -> Ascend MAX 4004




{looking at all the pretty lights on my 804 sitting next to me...)

The configurator crap that came with your 804 actually comes *very* close to
doing the job, but I still had to tweak my config a little bit.

I'm set up on a Centrex, so you'll see 4 digit dialing below.  I've also set
up to stay connected 24/7.  If you need dial and bandwidth on demand, you'll
need to adjust the idle-timeout and the load-threshold to better suit your
needs.

!
isdn switch-type basic-ni
!
interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 XXXXXXXXXXXXXX XXXX
 isdn spid2 XXXXXXXXXXXXXX XXXX
 ppp multilink
!
interface Dialer1
 ip address negotiated
 no ip directed-broadcast
 no ip proxy-arp
 encapsulation ppp
 no ip split-horizon
 dialer remote-name XXXXXXXXXX
 dialer idle-timeout 2147483
 dialer string XXXX
 dialer string XXXX
 dialer hold-queue 10
 dialer load-threshold 1 either
 dialer pool 1
 dialer-group 1
 pulse-time 0
 ppp pap sent-username XXXXXX password 7 XXXXXXXXXXXXX
 ppp multilink
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx deny
dialer-list 1 protocol bridge deny
!
!  If you need it, here's the DHCP config I'm using (love PnP networking :)
!
ip dhcp pool home
   network xxx.yyy.zzz.nnn xxx.yyy.zzz.nnn
   netbios-name-server xxx.yyy.zzz.nnn
   domain-name my-cool-domain.com
   dns-server xxx.yyy.zzz.nnn xxx.yyy.zzz.nnn xxx.yyy.zzz.nnn
   default-router xxx.yyy.zzz.nnn
   lease 7
!
!

--Troy

** -----Original Message-----
** From: owner-ascend-users@max.bungi.com
** [mailto:owner-ascend-users@max.bungi.com]On Behalf Of James A. Mutter
** Sent: Friday, December 17, 1999 10:14 PM
** Cc: ascend-users@bungi.com
** Subject: (ASCEND) Cisco 804 -> Ascend MAX 4004
**
**
** Can anyone help with this one?  Trying to get a Cisco 804 to connect to
** an Ascend MAX 4004
**
**
** I've been tinkering with this thing for a while now and I'm having some
** problems - I've also searched the web and come up empty.
**
** ISDN is up and running - spids are recognized and valid - I am being
** authenticated by the remote end (Ascend MAX 4004) -
**
** Problem is that I can't send packets out of or through the 804 through
** the BRI0 interface.  It's
** not NAT'ing the local network, it's not allowing packets to the internet
** that originate from the 804 as well.  My ISP says he can see that the
** unit is authenticated and assigned an IP - but he can't ping it either.
**
** Below is the current config.
** Following that is the output from a few 'show' commands.
**
** !
** version 12.0
** no service pad
** service timestamps debug uptime
** service timestamps log uptime
** service password-encryption
** !
** hostname border
** !
** logging buffered 8192 debugging
** enable password 7 XXXXX
** !
** username jmutter password 7 XXXXX
** !
** !
** !
** !
** clock timezone cst -6
** clock summer-time cdt recurring
** !
** dial-peer voice 1 pots
**  no forward-to-unused-port
**  call-waiting
**  ring 1
**  port 1
**  destination-pattern 1234567
** !
** dial-peer voice 2 pots
**  no forward-to-unused-port
**  call-waiting
**  ring 1
**  port 2
**  destination-pattern 1234567
** !
** pots country US
** ip subnet-zero
** no ip source-route
** !
** no ip domain-lookup
** isdn switch-type basic-dms100
** !
** !
** process-max-time 200
** !
** interface Ethernet0
**  description ***** local.net. *****
**  ip address 192.168.2.1 255.255.255.0
**  no ip directed-broadcast
**  no ip proxy-arp
**  ip nat inside
** !
** interface BRI0
**  description ***** ISDN LINE *****
**  no ip address
**  no ip directed-broadcast
**  encapsulation ppp
**  no ip mroute-cache
**  dialer pool-member 1
**  isdn switch-type basic-dms100
**  isdn spid1 12345678900101 4567890
**  isdn spid2 12345678900101 4567890
**  isdn voice-priority 4567890 in always
**  isdn voice-priority 4567890 out always
**  isdn voice-priority 4567890 in conditional
**  isdn voice-priority 4567890 out conditional
**  isdn incoming-voice modem
**  no fair-queue
**  compress stac
**  ppp authentication pap callin
**  ppp chap refuse
**  ppp multilink
** !
** interface Dialer0
**  no ip address
**  no ip directed-broadcast
**  no cdp enable
** !
** interface Dialer1
**  description ***** ds.net *****
**  ip address negotiated
**  no ip directed-broadcast
**  no ip proxy-arp
**  ip nat outside
**  encapsulation ppp
**  no ip split-horizon
**  no ip mroute-cache
**  no logging event link-status
**  dialer remote-name dmark1
**  dialer idle-timeout 300
**  dialer string 1234567 class dialclass
**  dialer hold-queue 10
**  dialer load-threshold 125 either
**  dialer pool 1
**  dialer-group 1
**  compress stac
**  pulse-time 0
**  ppp authentication pap callin
**  ppp pap sent-username jmutter password 7 XXXXX
**  ppp multilink bap
**  ppp bap call accept
**  ppp bap call request
**  ppp bap call timer 5
**  ppp bap drop timer 30
**  ppp bap timeout pending 20
**  ppp bap max dial-attempts 3
** !
** interface Dialer2
**  no ip address
**  no ip directed-broadcast
**  no logging event link-status
**  no cdp enable
** !
** ip nat inside source list 18 interface Dialer1 overload
** ip http server
** ip classless
** ip route 0.0.0.0 0.0.0.0 Dialer1
** !
** !
** map-class dialer DialClass
** access-list 18 permit 192.168.2.0 0.0.0.255
** access-list 100 deny   ip any host 255.255.255.255
** access-list 100 deny   eigrp any any
** access-list 100 deny   tcp any any eq 135
** access-list 100 deny   tcp any any eq 139
** access-list 100 deny   udp any any eq 135
** access-list 100 deny   udp any any eq netbios-ns
** access-list 100 deny   udp any any eq netbios-dgm
** access-list 100 deny   udp any any eq ntp
** access-list 100 permit ip any any
** dialer-list 1 protocol ip list 100
** banner motd 
**                           ++++++++++++++++++++++++++++++
**                           +     border.local.net.      +
**                           ++++++++++++++++++++++++++++++
**  
** !
** line con 0
**  exec-timeout 120 0
**  transport input none
**  stopbits 1
** line vty 0 4
**  exec-timeout 300 0
**  login local
** !
** sntp server 128.102.16.2
** sntp broadcast client
** end
**
** < -- end config -- >
**
** border#show isdn sta
** Global ISDN Switchtype = basic-dms100
** ISDN BRI0 interface
**         dsl 0, interface ISDN Switchtype = basic-dms100
**     Layer 1 Status:
**         ACTIVE
**     Layer 2 Status:
**         TEI = 79, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
**         TEI = 81, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
**     Spid Status:
**         TEI 79, ces = 1, state = 5(init)
**             spid1 configured, spid1 sent, spid1 valid
**             Endpoint ID Info: epsf = 0, usid = 70, tid = 1
**         TEI 81, ces = 2, state = 5(init)
**             spid2 configured, spid2 sent, spid2 valid
**             Endpoint ID Info: epsf = 0, usid = 71, tid = 1
**     Layer 3 Status:
**         0 Active Layer 3 Call(s)
**     Activated dsl 0 CCBs = 0
**     The Free Channel Mask:  0x80000003
**     Total Allocated ISDN CCBs = 0
** border#
**
** < -- end show isdn sta -- >
**
** border#show ip route
** Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
**        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
**        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
**        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
**        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
** inter area
**        * - candidate default, U - per-user static route, o - ODR
**        P - periodic downloaded static route
**
** Gateway of last resort is 0.0.0.0 to network 0.0.0.0
**
** C    192.168.2.0/24 is directly connected, Ethernet0
** S*   0.0.0.0/0 is directly connected, Dialer1
** border#
**
** < -- end show ip route -- >
**
** I'm not really sure where to go from here.  Any help is surely
** appreciated.
** ++ Ascend Users Mailing List ++
** To unsubscribe:	send unsubscribe to ascend-users-request@bungi.com
** To get FAQ'd:	<http://www.nealis.net/ascend/faq>
**

++ Ascend Users Mailing List ++
To unsubscribe:	send unsubscribe to ascend-users-request@bungi.com
To get FAQ'd:	<http://www.nealis.net/ascend/faq>